Page 1 of 1

LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Wed Jun 30, 2021 5:52 am
by teddyy80
I was playing the computer and had to go outside. I hit the live button and selected leave game. When I go back and select Hangtime my record that was 240-0 now has a loss on it, 240-1.

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Thu Jul 01, 2021 5:01 pm
by CodeMystics
That has nothing to do with the penalty system. No penalties have been recorded for you since June 17.

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Fri Jul 02, 2021 6:49 pm
by teddyy80
I never said anything about the penalty this time (which it did not assess me), just about the loss on record. If you play only the computer and leave the game or hold the player 2 button to reset the game or player 1 button to go to the leaderboard screen, that result doesn't count; whether you are winning or not. How could it count if you never finished the game?

Also did you ever solve the problem of my 999-1 record not showing up on the leaderboard after I play with that profile?

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Fri Jul 02, 2021 7:55 pm
by CodeMystics
We cannot speak for how the original game may assess wins or losses.

The 999-1 situation is as we previously mentioned: the original game's records start to malfunction after 1000 wins. The emulation reproduces this malfunction.

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Sat Jul 03, 2021 4:36 pm
by teddyy80
Even on the leaderboard?

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Sat Jul 03, 2021 11:24 pm
by CodeMystics
The record is maintained by the game. The leaderboard merely reflects the same data.

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Sun Jul 04, 2021 9:13 am
by teddyy80
Guess what? On my 999-1 profile (the one that I told you the game assessed me a loss on the other message board), it now shows 999-0 on the game screens (1023-0 on the best overall player screen under Hangtime). I just beat a guy and after the game was over my record said 999-0 on the screen before the quarter by quarter score screen. However, on the leaderboard it still shows 998-1 and it doesn't show that I just played under that profile on the best overall list on the leaderboard. Just thought you should know.

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Sun Jul 04, 2021 12:00 pm
by CodeMystics
Yes, the data corrupts between 1000 and 1023, and after 1023 it gets worse. The leaderboard system is ignoring the corrupt data.

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Sun Jul 04, 2021 6:46 pm
by teddyy80
Just wondering, is that anything you guys are trying to fix or planning on fixing?

Just played and won two games under that 999-0 profile. Now it says after the first win 0-999. Then after the second win it said 1-999.

Re: LOSS GIVEN AGAIN BUT THIS TIME I WAS PLAYING THE COMPUTER

Posted: Mon Jul 05, 2021 9:32 am
by CodeMystics
As we've said previously, altering arcade function in the original ROMs (outside removing things) is generally an impractical task. It is generally accepted that emulation reproduces the original game exactly, and that includes original bugs.

What you are seeing is what happens when you pass 1023 games in the arcade ROM. It has no storage capacity to go beyond 10 bits in your record. You have rolled over the score, as they say.

It's actually common in just about every arcade game. e.g. Defender only supports 6 digit scores, so if you manage to get to 1,023,450 your score would be 23,450.