Last Blade 2 (Steam version) random 30 fps issues

Having an issue with one of our games? Browse this section for answers to common problems, or post your own questions to get support from us.
Post Reply
Zecilus
Posts: 3
Joined: Mon Dec 11, 2017 4:06 pm

Last Blade 2 (Steam version) random 30 fps issues

Post by Zecilus » Mon Dec 11, 2017 4:14 pm

I have an issue with The Last Blade 2 on steam in which randomly my frame rate would seem to be at half refresh. Like the game goes into 30 fps. The shadows also become solid with only one shadow under one character at a time. This can happen when playing Story mode with or without multiplayer and in any stage with any character. Fullscreen or Windowed and in any Windows compatibility mode.

The only way to temporarily solve this problem is to pause the game and go into the player's move list menu then exit out. The problem then later resurfaces.

I have the latest Nvidia driver updates. (Dec 7) I have a Gsync monitor but I have tried the game with Gysnc enabled and disabled but no resolve.

My full computer specs are

Intel i7 3770K Quad core overclocked to 4.5Ghz
Asus STRIX GTX 1070 OC Edition
16 GB Corsair Vengeance 24000 DDR3
Asus P8P67 Deluxe Motherboard with latest BIOS rev.
Samsung EVO 850 1TB SSD
Asus Predator XB241H Gysnc monitor

User avatar
CodeMystics
Posts: 249
Joined: Mon Oct 13, 2014 3:22 pm

Re: Last Blade 2 (Steam version) random 30 fps issues

Post by CodeMystics » Mon Dec 11, 2017 10:05 pm

To be clear, the game does not slow down, correct? What do you have your desktop refresh rate set to?

Zecilus
Posts: 3
Joined: Mon Dec 11, 2017 4:06 pm

Re: Last Blade 2 (Steam version) random 30 fps issues

Post by Zecilus » Mon Dec 11, 2017 10:30 pm

The game does not slow down in the sense that things go in "slow motion" or slow to a crawl
It's like the game runs at half the refresh rate that it's supposed to. Almost like there's now a 30 fps cap put in temporarily. (Until I go into the move lists menu then back out)

The 'pacing" is the same but there's obviously the increased input delay that you would associate with a game going from 60fps down to 30fps

My desktop refresh rate is 144hz

There's also two other Steam forum users who posted similar issues to mine in the Last Blade 2 steam forums. One of them however runs a laptop and Alienware steam box. I'm willing to bet his laptop at least runs at 60hz

User avatar
CodeMystics
Posts: 249
Joined: Mon Oct 13, 2014 3:22 pm

Re: Last Blade 2 (Steam version) random 30 fps issues

Post by CodeMystics » Thu Dec 14, 2017 8:47 pm

Go to the game's Properties, select the Beta tab, choose the Beta branch, enter the password of "lb2betabranch" and click "CHECK CODE":
beta.png
beta.png (14.1 KiB) Viewed 1848 times
You should see "Access code correct, private beta 'beta' is now available."

Next, go to the General tab and select "SET LAUNCH OPTIONS..." and type "-max_catch_up=1":
option.png
option.png (20.5 KiB) Viewed 1848 times
Apply those changes, then make sure it downloads an update. You can confirm the update downloaded by viewing the Local Files tab:
confirm.png
confirm.png (14.18 KiB) Viewed 1848 times
It should say you are on build 2370607. If you do not see that number, click the "VERIFY INTEGRITY OF GAME FILES..." button and see if that changes things.

Once you've confirmed the update has downloaded, run the game, and let us know whether or not it helps.

Note: If the game stops dropping frames, but starts slowing down, then the problem is your driver is not letting the game run at 60 FPS.

Zecilus
Posts: 3
Joined: Mon Dec 11, 2017 4:06 pm

Re: Last Blade 2 (Steam version) random 30 fps issues

Post by Zecilus » Mon Dec 18, 2017 3:37 pm

I've done the following steps and double checked my command line spelling. The game confirms the same build you post as well as having the words (beta) next to the title in the Library list. Just to ensure no issues I re-verified the integrity of game files. The issue seems to persist. What's weird is the problem being resolved by checking your character's move list

I've downloaded the latest Nvidia drivers as well (dated Dec 7)

Post Reply